This error shows up when you change/upgrade the PHP version of your Joomla website to PHP 7.XX.

This is because the mysql extension is removed in PHP 7. You may need to change all those functions in PHP code to mysqli_* instead of mysql_* if you want to use PHP 7 for your Joomla website.

In cPanel EasyApache 4, the mysqli extension is provided by the mysqlnd package.

For example:

root@server [~]# rpm -qa | grep ea-php7 | grep mysqlnd
ea-php70-php-mysqlnd-7.0.33-9.9.1.cpanel.x86_64
ea-php71-php-mysqlnd-7.1.30-4.4.1.cpanel.x86_64
ea-php72-php-mysqlnd-7.2.20-3.3.1.cpanel.x86_64